"Series AI" and "AI" buttons failing to appear in XVWeb
Behavior:
The following buttons do not appear when viewing a series within XVWeb, preventing the AI function from being usable:
Causes:
- The Location drop-down is set to a location that does not have the AI integration enabled, or does not have Show AI enabled
- The Location drop-down is set to a location that does not have the modality enabled that is being viewed
- AI integration is not yet enabled for your practice's location
- AI integration is not yet enabled for your XVWeb site
- This behavior could be caused by the browser's inability to store cookies. The remembered AI pathologies as well as the location specified in the Location drop-down are stored in the cookies that are produced by XVWeb - if the browser is running in a way that prevents cookie storage/saving between browser sessions, this issue will be seen
- DENTICON ONLY: Locations in XVWeb are missing PMSIDs.
- If Denticon is in use by your practice, ensure the office name/OID you are viewing in Denticon is correct, and the locations within XVWeb contain PMSIDs that match the OID of the respective Denticon location. This will ensure the correct location is passed over to XVWeb.
Solutions:
- Verify the modality of the series/images being viewed is a modality supported by the AI vendor - typically IO, PX, DX, or HC. Unsupported modalities will not allow the AI buttons to appear.
- Ensure the Location drop-down is set to the correct, AI enabled location. The drop-down is located in the top-right corner, to the left of your username:
- If the Location drop-down is set to the correct location and the series being viewed is of a supported modality, but the Series AI and AI buttons still fail to appear, please submit a ticket so our support team can investigate further.
- Ensure your preferred/default browser is allowed to store cookies and other site data, and is not running in Guest Mode, under a guest profile, or otherwise configured in a way that causes cookies to be rejected or removed every time the browser is closed.
- If Denticon is in use by your practice: Ensure the office name/OID you are viewing in Denticon is correct, and the locations within XVWeb contain PMSIDs that match the OIDs of each respective location in Denticon.
- PMSIDs can be set by logging into XVWeb as admin, clicking on your username, then navigating to Location Management. Click on your AI-enabled location, then set the PMSID to match the OID of the respective location in Denticon. This will allow Denticon to pass the correct location to XVWeb automatically.
Browser settings and configurations are not directly supported by or managed by Planet DDS, and would require the practice's local IT provider to reconfigure the browser in a way that allows for cookies and other site data to be stored moving forward.
________________________________________________________________________________________________________________
AI results not appearing on recently captured images
Behavior:
After a series of images is captured and forwarded to XVWeb, AI results are not visible on the newly captured images, but AI results can be displayed on previously captured images.
Causes:
- The AI request is in a Pending state
- The AI Vendor did not detect any potential pathologies within the image(s)
- The Capture Station where the series of images was captured is unassigned, or is assigned to a location that does not have AI enabled
-
The Location drop-down is set to a location that:
- is set to a location that does not have AI enabled
- does not have the modality enabled that is being viewed
-
The modality on the image series in XVWeb is not set to IO, PX, DX, or HC
- ⚠️ PX images are not always expected to get AI results. Your AI Vendor would have to confirm expected behavior regarding PX modality images.
Solutions:
- To determine if the AI request is in a Pending state, click on an image in the recently captured series, then click the button labeled "AI" on the bottom toolbar that appears. The status of the AI request will be shown on the right side of the screen. Once the results have been received by us from the vendor, AI pathologies will become visible.
- Example of a Pending request, where AI results are not yet available:
- Example of a completed request, where AI results are available:
- Example of a Pending request, where AI results are not yet available:
- Verify the modality of the series/images being viewed is a modality supported by the AI vendor - typically IO or PX. Unsupported modalities will not allow for AI results to be requested from the vendor.
- Verify the Capture Station where the recently captured images were taken is mapped to the correct, AI enabled location - see Managing Capture Stations to confirm the Capture Station is mapped, and map it to the correct location if not already.
- To determine if the AI vendor simply did not detect any potential pathologies, click on an image in the recently captured series, then click the button labeled "AI" on the bottom toolbar that appears. The status of the AI request will be shown on the right side of the screen. If all pathologies show a yellow "!" symbol next to them, this indicates the AI did not detect any pathologies to display.
- Example of an image where no pathologies were detected, therefore AI results do not display:
- Example of an image where no pathologies were detected, therefore AI results do not display:
- If you find AI results are still not visible after confirming the Capture Station is properly mapped and the series being viewed is of a supported modality, or if you find an AI request has been stuck on Pending for an extended period of time, please submit a ticket so our support team can investigate further.
________________________________________________________________________________________________________________
AI results not appearing on historical images
For practices integrating AI with PMS: If your AI Vendor integrates with your Practice Management Software, you'll need a 12- or 18-month historical image extract. This is usually included when AI is enabled for your site and can take weeks, so confirm the ETA with your AI Vendor. For older images, view the series in XVWeb to request AI analysis.
For practices not integrating AI with PMS: If you're using AI Overlay features in XVWeb without PMS integration, then a historical extract is not included in that process, so AI results are only expected to appear on images captured after AI was enabled. For AI analysis on images older than the date your location went live with AI, view the series in XVWeb to request AI analysis.
Behavior:
When viewing converted images, or images acquired prior to the enablement of AI, AI results are not visible.
Causes:
- the AI request is in a Pending state - AI requests on historical images (image taken prior to the enablement of AI) take a longer time to process, and AI requests are not sent to the vendor until a historical series is viewed.
-
Specific to Pearl: Images that have a capture date of "Today" are expected to have a fast response, within 10 minutes at most. However, if the capture date on the images themselves are from a date prior to the date the request is sent, the images are sent to a Low Priority Queue on Pearl's side with an expectation to receive results within 72 hours from the time the request was sent. On average, we see around 48 hours to get a response from Pearl.
-
Specific to Pearl: Images that have a capture date of "Today" are expected to have a fast response, within 10 minutes at most. However, if the capture date on the images themselves are from a date prior to the date the request is sent, the images are sent to a Low Priority Queue on Pearl's side with an expectation to receive results within 72 hours from the time the request was sent. On average, we see around 48 hours to get a response from Pearl.
- The AI did not detect any potential pathologies within the image(s)
- The Capture Station where the series of images was captured is unmapped, or is mapped to a location that does not have AI enabled
- The Location drop-down is set to a location that does not have the modality enabled that is being viewed, or is set to a location that does not have AI enabled
Solutions:
- To determine if the AI request is in a Pending state, click on an image in the recently captured series, then click the button labeled "AI" on the bottom toolbar that appears. The status of the AI request will be shown on the right side of the screen. Once the results have been received by us from the vendor, AI pathologies will become visible.
- Example of a Pending request, where AI results are not yet available:
- Example of a Pending request, where AI results are not yet available:
- Verify the modality of the series/images being viewed is a modality supported by the AI vendor - typically IO, PX, DX, or HC. Unsupported modalities will not allow for AI results to be requested from the vendor.
- Verify the Capture Station where the historical images were taken or converted from is mapped to the correct, AI enabled location - see Managing Capture Stations to confirm the Capture Station is mapped, and map it to the correct location if not already.
- To determine if the AI vendor simply did not detect any potential pathologies, click on an image in the recently captured series, then click the button labeled "AI" on the bottom toolbar that appears. The status of the AI request will be shown on the right side of the screen. If all pathologies show a yellow "!" symbol next to them, this indicates the AI did not detect any pathologies to display.
- Example of an image where no pathologies were detected, therefore AI results do not display:
- Example of an image where no pathologies were detected, therefore AI results do not display:
- If you find AI results are still not visible after confirming the Capture Station is properly mapped and the series being viewed is of a supported modality, or if you find an AI request has been stuck on Pending for an extended period of time, please submit a ticket so our support team can investigate further.
________________________________________________________________________________________________________________
Certain pathologies unavailable when reviewing AI results
Behavior:
When reviewing AI results on a particular image or series, not all pathologies are displayed. For example, Caries are an available pathology on one image, but are not available on a different image.
Cause:
When AI results are returned to XVWeb by the AI vendor, only detected pathologies will display and appear as a selectable option when clicking the "AI" button from the bottom toolbar.
- Example of an image where the only detected pathology was "Measurements." Note that "Caries" does not appear as an option, as no potential Caries were detected:
- Example of an image where both "Measurements" and "Caries" were detected:
________________________________________________________________________________________________________________
Selected AI pathologies are not remembered between series, location specified in the Location drop-down does not save
Behaviors:
- When viewing an image in XVWeb, then navigating to the AI menu by clicking the image > clicking the AI button, the pathologies selected as preferred are not starred/enabled by default upon viewing a different series of images. This causes the user to have to select the pathologies they'd like to view every time a different series is viewed.
- Additionally, the location specified in the Location drop-down fails to save, causing the user to have to manually select the correct location each time XVWeb is opened.
Cause:
- Both of the above behaviors are directly caused by the browser's inability to store cookies. The remembered AI pathologies as well as the location specified in the Location drop-down are stored in the cookies that are produced by XVWeb - if the browser is running in a way that prevents cookie storage/saving between browser sessions, this issue will be seen.
- DENTICON ONLY: Locations in XVWeb are missing PMSIDs.
- If Denticon is in use by your practice, ensure the office name/OID you are viewing in Denticon is correct, and the locations within XVWeb contain PMSIDs that match the OID of the respective Denticon location. This will ensure the correct location is passed over to XVWeb.
Solution:
- Ensure your preferred/default browser is allowed to store cookies and other site data, and is not running in Guest Mode, under a guest profile, or otherwise configured in a way that causes cookies to be rejected or removed every time the browser is closed.
- If Denticon is in use by your practice: Ensure the office name/OID you are viewing in Denticon is correct, and the locations within XVWeb contain PMSIDs that match the OIDs of each respective location in Denticon.
- PMSIDs can be set by logging into XVWeb as admin, clicking on your username, then navigating to Location Management. Click on your AI-enabled location, then set the PMSID to match the OID of the respective location in Denticon. This will allow Denticon to pass the correct location to XVWeb automatically.
Browser settings and configurations are not directly supported by or managed by Planet DDS, and would require the practice's local IT provider to reconfigure the browser in a way that allows for cookies and other site data to be stored moving forward.
________________________________________________________________________________________________________________
AI results appearing on images, but Series AI and AI buttons are missing
Behavior:
AI results are automatically appearing on x-ray images, however the Series AI and AI buttons both fail to appear. This causes the user to be unable to toggle or disable AI findings on that particular series:
Cause:
This occurs when XC modality images (IO camera images) were captured into a series first, then additional IO modality images (x-ray images) were captured into the same series afterwards. This causes the x-ray images that were captured to be assigned a modality of XC instead of IO once they have saved into the layout. This also causes the entire layout to be saved as XC modality rather than a mixed modality layout.
When our DICOM server receives the files, the x-rays are still technically IO modality. As AI processing and the AI buttons are only available on IO, PX, DX, and HC modality images, they are sent for AI processing. However, since the series and all images contained in it are marked as XC modality, the AI buttons do not appear.
Solutions:
- To correct existing layouts where this has occurred, utilize the Select tool to select all x-ray images that are stored within the layout, then use the Edit tool to assign them to a new series. This will separate the x-rays from the XC modality series, and place them into an IO modality series where the AI buttons will be usable.
- To mitigate occurrences of this behavior, it is recommended to capture x-rays into a new study/series during image capture, rather than capture the x-rays as additional images into the same series that the XC modality images were captured into. This will allow for the image to be separated into their own series from the start, preventing users from having to manually separate them later.
- If the practice needs XC and IO modality images to remain in the same series for any reason, the use of a mixed modality layout is necessary to assign the x-rays the correct modality (IO).
Article Version 1.2 2026.6.8